Striim 3.9.6 documentation

In-place upgrade

An in-place upgrade installs the new version of Striim while keeping the current repository database. You may do an in-place upgrade to Striim 3.9.6 from version 3.9.5 or 3.9.5.1.

  1. Back up the cluster as described in Backing up and restoring a cluster.

  2. Stop all Forwarding Agents.

  3. Upgrade all servers:

    For Centos: on each server in the cluster, download striim-node-3.9.6-Linux.rpm and enter the following commands (on CentOS 6, omit systemctl):

    sudo systemctl stop striim-node
    sudo rpm -e striim-node
    sudo rpm -ivh striim-node-3.9.6-Linux.rpm 

    For Ubuntu: on each server in the cluster, download striim-node-3.9.6-Linux.deb and enter the following commands (on Ubuntu 14.04, omit systemctl):

    sudo systemctl stop striim-node
    sudo dpkg --remove striim-node
    sudo dpkg -i striim-node-3.9.6-Linux. 
  4. If you have installed the Cassandra wrapper (cassandra-jdbc-wrapper-<version>.jar), delete it from striim/lib, since starting with release 3.9.6 a custom driver is bundled with Striim.

  5. On the server running Derby, or, if using Oracle or PostgreSQL, on any one server in the cluster, run the appropriate script to update the schema of your metadata repository:

    • for Derby: /opt/striim/conf/UpgradeMetadataReposDerbyTo396.sql

    • for Oracle: /opt/striim/conf/UpgradeMetadataReposOracleTo396.sql

    • for PostgreSQL: /opt/striim/conf/UpgradeMetadataReposPostgresTo396.sql

  6. Start all servers.

  7. Upgrade and start all Forwarding Agents (see Upgrading Forwarding Agents).